Error Manual
Here, you will find a list of common status codes, errors, their meanings, and potential solutions to resolve them.
Overview
The CiiRUS Partner-API employs standard HTTP status codes to indicate the success or failure of requests. These familiar codes help you quickly identify the status of your API interactions. Whether your request is successful or encounters an issue, you'll receive an appropriate HTTP status code that provides valuable feedback on the outcome. This consistency ensures a clear and standardized approach, simplifying your integration process and helping you to address any errors efficiently.
HTTP Status Codes
| Error Code | Description |
|---|---|
200 OK | The request succeeded |
303 See Other | The server sent this response to direct the client to get the requested resource at another URI with a GET request |
400 Bad Request | The server is unable or unwilling to process the request due to a perceived issue on the client side |
401 Unauthorized | The provided Authentication values are not valid |
403 Forbidden | The client does not have access rights to the content |
404 Not Found | The server cannot find the requested resource. In the browser, this means the URL is not recognized. In an API, this can also mean that the endpoint is valid but the resource itself does not exist. |
422 Unproccessable Content | The request was well-formed but was unable to be followed due to semantic errors. |
500 Internal Server Error | The server has encountered a situation it does not know how to handle |
503 Service Unavailable | The server is not ready to handle the request. Common causes are a server that is down for maintenance or that is overloaded |
Error Reasons
Please be aware that the list of error reasons is continuously evolving. If you encounter an error not listed below, don't hesitate to create a support ticket via CiiRUS Support. You can access the support ticket submission page here.
Within each section provided below, you'll discover a list of potential error reasons that might be encountered from various API endpoints. Alongside each error reason, we've included a detailed explanation of its cause and the appropriate steps to resolve the issue:
All Endpoints
The error reasons detailed in this section apply across all endpoints.
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Inventory
"Property has been deleted."
Cause
The SUPPLIER has deleted this property from its inventory.
Resolution
This is not a technical error - this is a message indicating that the property has been deleted - do not enable this property to your Inventory.
"Property supplier has disabled this property for all agent connections."
Cause
The SUPPLIER has not enabled this property for any AGENT connections.
Resolution
Confirm with the SUPPLIER if this property should be enabled for AGENT connections. If yes, advise the SUPPLIER to enable the property to all channels. If no, do not enable this property to your Inventory.
"Property supplier has not enabled this property."
Cause
The SUPPLIER has not enabled this property to your AGENT connection.
Resolution
Confirm with the SUPPLIER if this property should be enabled for your AGENT connection. If yes, advise the SUPPLIER to enable the property to for your AGENT. If no, do not enable this property to your Inventory.
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Reservations
Service Unavailable
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As this is a highly robust API function, a
Service Unavailable error commonly arises when the API service encounters difficulties processing the request due to an excessive number of records being returned.
Resolution
Leverage the available parameters to refine the data retrieval, allowing you to obtain only the specific data you need. This approach can help mitigate the "Service Unavailable" error.
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Suppliers
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Updated 3 months ago
